You are currently browsing the category archive for the ‘Media Center 2005’ category.

image

Due to the need to trim the home budget, and the fact that the guide blew up again (channel changes), which bought the mace of marital wrath down upon my forehead, I’ve moved from IceTV to the cheaper alternative of EPGStream.

I stuck with ICETV for a year longer than I intended because of their good work against Channel 9, but I cannot justify the cost any longer.

I still recommend IceTV for a great experience.  The ability access your EPG via phone is also really good.

EPG Stream is pretty straight forward to set up.  They are very clever about ensuring that you donate, but I don’t mind.  The service is good.  (Although I didn’t know this when I had to donate)

image

 

If you’re into iTunes (thanks to the iPhone I’m starting to be) and want to integrate with Media Center, you could take a look at MCE Tunes.

http://www.mcetunes.com

image

I have no idea why, but channel 10 decided to rename themselves to “ONE” in the IceTV guide, causing havoc on the home front.  Previously scheduled recordings were lost, channels vanished and shenanigans ensued.

I guess this is another reason why Media Center is just “too hard” for the average consumer.  “Rescanning” doesn’t help much.  To make things work again involves some heavy duty fiddling with settings.  Although we all love it, the media center user experience is terrible when you’re trying to fix settings.

I used the opportunity to encourage an upgrade to Vista…..still no luck there.

 

Web Media

 

 

 

 

 

For quite some time I’ve been using internet radio with media center.  This is all thanks to the “Web Media” addin from mcesoft.

The setup is somewhat primitive (want to type an internet radio url anyone?), but once it’s going, it works well without any problems.

 

Links

 

Web Media Download

How to get Internet radio working in MCE at a click of a button

Some skipping action

The past few months of Media Center XP has been fairly uneventful, thus the lack of commentary.

Just a brief note about skipping during playback.  It is common for hard drives containing recorded television programs to become badly fragmented.  I think this happens on our computer because we tend to record so many programs, yet only watch a few.

Also, television program files are quite large (haven’t been brave enough to start compressing them yet) which makes defrag difficult.

Nevertheless, it’s necessary to run defrag frequently.  I recommend that you delete all unnecessary tv programs beforehand, as we do.

 

image

 

Share this post :

The FusionRemote remote control

Today’s problem is not to moan about media center, but instead to moan about my remote control.

I use an IR remote control that plugs in to my DIVCO Dual tuner card.

This one is particularly well regarded by some people as it comes with the card and is quite useable with media center most of the time.

Sometimes however it doesn’t work. This doesn’t go down well with “She who uses the media center”. “Sometimes not working” is not what she wants from a remote control. (Thats what she wants from the media center as well….well don’t push your luck).

When she presses on the buttons and media center doesn’t respond you may think nothing is happening. That isn’t true! Something IS happening. She’s getting angrier and angrier at me…..

Anyway, here are my problems and tips to make your FusionRemote work most of the time.

Problem : FusionTray keeps vanishing (so the remote doesn’t work)

The exe FusionRemote.exe is located at “C:\Program Files\DVICO\FusionHDTV\Remote\FusionRC.exe” on my computer. If you use a standalone install it may be installed in “C:\Program Files\DVICO\”. Ironically it appears the former one is more up-to-date than the later. (ie It doesn’t have this problem). I recommend (at them moment) to use the one in the fusionhdtv subdirectory.

Problem: Stupid error message when FusionTray runs (so the remote doesn’t work)

This one happens if you use the default “autorun” capability of the remote. They never seem to get around to fixing it.

Switch off “Autorun”, then copy the “Fusion Remote Tranceiver” shortcut to your “Startup” folder instead.

Problem : FusionTray runs but the remote still doesn’t work

Unplug the IR receiver from it’s port at the back of the tuner card, then plug it back in.

It should work now.

Problem: FusionRemote won’t run on Vista (so the remote doesn’t work)

Well of COURSE it doesn’t! They’d be expecting that!

This is doesn’t work because of Vista permissions.

You need to set the startup shortcut to run as Administrator.

Full instructions here:

http://www.fusionhdtv.co.kr/Eng/Support/FAQRemote.aspx?act=RD&id=273&pg=0&CATID=13

Vista you ask? No…still running Media Center 2005.

Currently I dual boot Media Center 2005 and Vista Ultimate. (She believes this is causing the problem with the remote…..another story) Currently Vista Media Center has terrible performance on HDTV, but I have bought a new video card (arriving soon) that may assist with this.

In my last thrilling instalment my wife came home to a “new” media center.  Not only are all channels working, but I decided to tune in some of those new high definition stations….

CPU usage for viewing a HD channel has now increased by 40%.  If you record a HD channel you get yet more CPU usage….sigh.

So SD channels are fine, but HD channels definitely use more juice.

The situation has been made tolerable by removing Yahoo Widgets and shutting down a few more non-essential services.

Why don’t we just avoid HD?  In Australia there are extra programs on HD that differ from the usual.

Why is it so?

My current theory is that my HP Pavilion a1515a media center lacks a DXVA compliant video card.

DXVA means hardware decoding of MPEG-2 data.  I assume the higher resolution of HD means more stuff to decode.

My current strategy is to buy a DXVA compliant card.  Will let you know how it goes.

Vista Media Center

I recently installed a copy of Windows Vista on another partition.  I was kind of hoping the experience may be different.

Sadly I have to report that the default experience was not great for two reasons:

1. Seems to use more CPU, which means even worse stuttering for HD (SD Digital is ok though)

2. Vista Update keeps applying some update which blue-screens the computer on startup.  I keep having to restart in safe mode and uninstall the cursed things.  I suspect this is due to a driver incompatibility, so hopefully the new card will help with this too.

I’ll be dual booting for a while and comparing the experience.  More posts about this in the future too.

image

So things were going fine, then….they weren’t.

We kept losing the ABC TV channels, which upset our 2 year old greatly, as “ABC Kids” is one of her most beloved programs.   Lets say I had a huge incentive to fix it.

Continually rescanning would not bring back ABC2 and ABC was only there part of the time.

(Not to mention the return of ….. stuttering)

When media center crashes, it sometimes leaves a log here:

    C:\WINDOWS\ehome\ehshell.crash

This is a text file containing a “.net” stack trace.

Unhandled Exception – 13/03/2008 8:43:44 PM
Message: No tune request available for service
Exception:
System.ArgumentException: No tune request available for service
at Microsoft.Ehome.Epg.ServiceDb.LoadCurrentTuneRequests()
at Microsoft.Ehome.Epg.ServiceDb.get_TuneRequests()
at Microsoft.Ehome.Epg.ServiceDb.get_DefaultTuneRequest()
at Microsoft.Ehome.Epg.ChannelDb.get_TuneRequest()
at MediaCenter.Video.VideoBroadcastMedia.get_TuneRequest()
at MediaCenter.Video.VideoMedia.IsHD(IMedia media)
at MediaCenter.Video.VideoMedia.ShowLogo(IMedia media)
at MediaCenter.Video.VideoGuidePage.ShowInfo(IMedia mediaShow, String title, String description, String otherInfo, String recordGlyph)
at MediaCenter.Video.VideoGuidePage.ShowProgramInfo(VideoBroadcastShowMedia mediaShow)
at MediaCenter.Video.VideoGuidePage.ShowSelectionInfo()
at MediaCenter.Video.VideoGuidePage.OnWaitToShowDescriptionTick(Object sender, EventArgs e)
at eHome.UI.Timer.CallTickHandlers(TimerCallback callback)
at eHome.UI.TimerCallback.Dispatch()
at eHome.UI.Dispatcher.MainLoopBody(Feeder feeder)
at eHome.UI.Dispatcher.MainLoop(LoopCondition condition, LoopBody body)
at eHome.UI.Dispatcher.MainLoop(LoopCondition loopCondition)
at eHome.UI.Application.Run()
at ServiceBus.UIFramework.PageBasedUCPService.Run()
at ServiceBus.UIFramework.UserControlPoint.Main(String[] args)

Naturally this is not of much use.

Researching around I heard the best thing to do is reconfigure from scratch.

Step 1 – Reset

A great program to do this is the “Media Center Configuration Reset Program”.  It worked for me.

Step 2 – Channel selection, Reordering, Guide Assignment etc

I was then shown the initial scan screen, which I dutifully ran through.  (As it turns out, several times)

The truly boring part is using the Media Center Ui to remove and reorder all the endless duplicated channels.  I was very nervous while doing this because this was the screen that originally crashed.

I was really confused about the various providers having Digital, HD or just plain to choose from.   For example:

  • Seven
  • Seven Digital
  • Seven Digital 1
  • Seven Digital 2
  • Seven Digital 3
  • Seven HD
  • Seven Guide

With some of these duplicated several times.  Huh?  Isn’t this a HD tuner, aren’t they all supposed to be HD? 

Anyway, I decided to choose things with a “HD” branding by preference, except for ABC, which seemed to have ABC1, ABC2 and ABC HDTV. 

Sigh.

Step 3 – Backup

Another program I used is Ian Dixon’s MCE Backup Program. It made me feel that maybe I won’t have to go through this again. 😉

Step 4 – Get into some more trouble

Because it’s a day of adventure (my wife is away this week) I also am trialling ICETV’s remote recording software.

It seems good, but so far the programs I want it to record have not appeared in my MCE Guide Scheduler.  I can only assume that your computer has to be online at the time of recording, then they will initiate the recording.  This may be annoying for my spouse, who is used to seeing the schedule information in the MCE guide.

image

Problem

We’ve had a problem for the last few months in media center where the first channel we switch to on "My TV" has normal video but double speed sound.   We describe this as the "chipmunk" effect.  This also happens for some DVDs.  I suspect this happens the "first time" video is shown after the computer is booted.

It doesn’t happen with music or videos, so I’m assuming it’s some problem with the mpeg2 codec.  (The codec used for DVDs and digital TV).

Well not the codec exactly, for if I switch codecs using DECCHECK exactly the same problem happens.

I suspect that the problem is related to the NVIDIA codec trial expiring ages ago.  (I have subsequently bought the codec and it works fine…except for this problem, which I don’t think is specifically related to the codec)

The problem doesn’t happen when I used Media Player to play a video, so  it seems to be a media center specific problem.

Workaround

I haven’t been looking for a solution (until now) as the novelty value still hasn’t worn off.  (For some reason my family still finds this hilarious)

Solution

I haven’t been able to find a solution to this problem.   Has anyone else experienced this problem?

Dr Who. who insisted on going down to the city and in peril from the daleks, but not responsible for problems on my Media Center 

The Dead Planet

Travelling to a desolate and seemingly dead planet, the Doctor and his companions find a city which seems virtually untouched.  The Doctor tricks his companions into an expedition down to the city in order to take a closer look at it.  He does this by convincing them that the TARDIS requires some mercury for a part called a"fluid link" to repair it.

The planet is Skaro and the inhabitants turn out to be the race that are to become his greatest adversaries…..

As it turns out, my latest Media Center (MCE 2005) journey had a few parallels with the plot of the DVD which started the problem in the first place….

My kids are going through a bit of a Doctor Who phase at the moment, and as a result we borrowed four DVDs from the council library.  The first 3 were remastered versions of the original first 3 episodes.

As it turns out, library DVDs tend to get very scratched.  In this case we had all sorts of trouble playing the second DVD.    We had to give up on this one, just as Susan had the frightening encounter with the Thal in the radioactive forest….

The Survivors

The third and subsequent DVDs played then started exhibiting a very strange problem.  The DVD sound was distorted and the playback was jerky.  More investigation revealed that audio CDs also "crackled".

I finally isolated the problem to the DVD player itself.  I cleaned it using a CD cleaning kit. (About 8 times) I then proceeded to clean it with a cotton bud.  Neither of these actions produced any result.

The Escape

Was the problem software?  Much googling revealed the problem.  Apparently an IDE DVD player on a computer has two modes of operation, DMA mode (Direct Memory Access) and PIO Mode (Parallel IO?).

The Ambush

DMA mode allows data to be transferred directly from the DVD to memory, which makes it very fast and efficient.  PIO mode requires the interaction of the processor, which isn’t so fast (especially with Media Center trying to render video etc at the same time).

The Expedition

Apparently Windows XP has a feature that switches automatically from DMA to PIO when trying to read a scratched disk, as PIO mode is more tolerant of problems.

The Ordeal

The bad news is that it stays in this mode, resulting in stuttering DVD playback and crackling CD audio.  This change is permanent (it survives reboots).

The Rescue

Fortunately, just like the 1963 footage of the early episodes of Dr Who were remastered back to their original condition, it’s possible to switch Windows XP back to using DMA.

The following excellent article provides a vb script (that worked for me) that does this:

DMA reverts to PIO

My wife is returning from a trip away tomorrow and doesn’t like me "playing around" with "her" media center.  This information has saved me and hopefully (via Google) this information may save some of you also.

Links

Share this post :